Installing OCaml and Camlp5

From GeneWeb
Revision as of 18:37, 1 January 2016 by Guillaumebrochu (Talk | contribs) (erreur de frappe)

Jump to: navigation, search

Compiling GeneWeb requires the installation of OCaml and Camlp5.

Installing OCaml and Camlp5 through OPAM (OCaml preferred package manager) allows installation of the two versions of OCaml needed for GeneWeb:

  • Old GeneWeb versions (lower than 7.00) should be compiled with OCaml version 3.12.1.
  • Starting at version 7.00, GeneWeb can be compiled with latest OCaml 4.02.3. Camlp5 must be installed for each version of the compiler.

If your base has been built under an old version, it won't be compatible with bases built with new version: one should recover through the .gw format to migrate from one to the other.

Under Windows using Cygwin

  • Install Cygwin using last setup-x86_64.exe found on http://cygwin.com/.
    • This step can be done silently in a bash script containing the list of needed packets using installcygwin.bat.
  • Open Cygwinr terminal to install OCaml and Camlp5.
  • Install OCaml 3.12 or 4.02 depending on GeneWeb version you want to compile.
  • Install Camlp5.
  • You can now use GeneWeb repository to compil GeneWeb.

Under Linux

Tested on debian-8.2.0-i386-netinst.iso, to install opam/ocaml (4.02.3)/camlp5 (6.14)/ocamlfind:

apt-get install opam
opam init
opam switch 4.02.3
eval 'opam config env'
opam install camlp5
opam install ocamlfind