Installing Ocaml

From GeneWeb
Revision as of 22:58, 14 October 2015 by Henri83 (Talk | contribs) (Created page with "{{DISPLAYTITLE:Installing Ocaml}} Compiling GeneWeb requires installation of: * '''Ocaml''' * '''camlp5''' These can be found at http://ocaml.org. One good way of installi...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search


Compiling GeneWeb requires installation of:

  • Ocaml
  • camlp5

These can be found at http://ocaml.org.

One good way of installing Ocaml and camlp5 is to do it through opam, Ocaml preferred package manager. One benefit is to allow installation of the two version of Ocaml appropriate for GeneWeb 3.12.1 and 4.02 (current version 4.02.3).

Warning: camlp5 must be re-installed for each version of the compiler.

  • Versions lower than 7.00 of GeneWeb should be compiled with Ocaml version 3.12.1
  • Starting at version 7.00, GeneWeb can be compiled with Ocaml version 4.02.3

Bases built with GeneWeb compiled with one version are not compatible with bases built with GeneWeb compiled with another version. One should transit through the .gw format to move from one to the other.