Difference between revisions of "OCaml"

From GeneWeb
Jump to: navigation, search
m (A2 moved page Ocaml to OCaml: typo. Objective Caml)
(reformulation + installation Win grossière (à détailler plus avec les scripts adéquat + retester OPAM sous Win))
Line 1: Line 1:
{{DISPLAYTITLE:Installing Ocaml}}
+
{{DISPLAYTITLE:Installing OCaml and Camlp5}}
 +
Compiling GeneWeb requires the '''installation of [http://ocaml.org/ OCaml] and [http://camlp5.gforge.inria.fr/ Camlp5]'''.
  
Compiling GeneWeb  requires installation of:
+
Installing OCaml and Camlp5 through [http://opam.ocaml.org/ OPAM] (OCaml preferred package manager) allows installation of the two versions of OCaml needed for GeneWeb:
* '''Ocaml'''
+
* '''Old GeneWeb versions (lower than 7.00) should be compiled with OCaml version 3.12.1'''.
* '''camlp5'''
+
* Starting at version 7.00, GeneWeb can be compiled with latest OCaml 4.02.3. Camlp5 must be installed for each version of the compiler.
  
These can be found at http://ocaml.org.
+
If your base has been built under an old version, it won't be compatible with bases built with new version: one should [[recover]] through the [[GWformat|'''.gw''' format]] to migrate from one to the other.
  
One good way of installing Ocaml and camlp5 is to do it through opam, Ocaml preferred package manager. One benefit is to allow installation of the two version of Ocaml appropriate for GeneWeb 3.12.1 and 4.02 (current version 4.02.3).
+
== Under Windows using Cygwin ==
 
+
* Install Cygwin using last setup-x86_64.exe found on http://cygwin.com/.  
Warning: camlp5 must be re-installed for each version of the compiler.
+
** This step can be done silently in a bash script containing the list of needed packets using {{c|[[installcygwin.bat]]}}.
 
+
* Open Cygwinr terminal to install OCaml and Camlp5.
* Versions lower than 7.00 of GeneWeb should be compiled with Ocaml version 3.12.1
+
* Install OCaml 3.12 or 4.02 depending on GeneWeb version you want to compil.
* Starting at version 7.00, GeneWeb can be compiled with Ocaml version 4.02.3
+
* Install Camlp5.
 
+
* You can now use GeneWeb [[repository]] to [[compilation|compil GeneWeb]].
Bases built with GeneWeb compiled with one version are not compatible with bases built with GeneWeb compiled with another version. One should transit through the '''.gw''' format to move from one to the other.
+

Revision as of 02:30, 15 October 2015

Compiling GeneWeb requires the installation of OCaml and Camlp5.

Installing OCaml and Camlp5 through OPAM (OCaml preferred package manager) allows installation of the two versions of OCaml needed for GeneWeb:

  • Old GeneWeb versions (lower than 7.00) should be compiled with OCaml version 3.12.1.
  • Starting at version 7.00, GeneWeb can be compiled with latest OCaml 4.02.3. Camlp5 must be installed for each version of the compiler.

If your base has been built under an old version, it won't be compatible with bases built with new version: one should recover through the .gw format to migrate from one to the other.

Under Windows using Cygwin

  • Install Cygwin using last setup-x86_64.exe found on http://cygwin.com/.
    • This step can be done silently in a bash script containing the list of needed packets using installcygwin.bat.
  • Open Cygwinr terminal to install OCaml and Camlp5.
  • Install OCaml 3.12 or 4.02 depending on GeneWeb version you want to compil.
  • Install Camlp5.
  • You can now use GeneWeb repository to compil GeneWeb.