Installer OCaml et Camlp5 pour compiler GeneWeb

From GeneWeb
Revision as of 19:32, 31 January 2019 by Hiob (Talk | contribs) (first line)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
150px-Geographylogo svg.png Language: English • Deutsch • français • Nederlands • svenska

Compiler GeneWeb requiert l'installation de OCaml et de Camlp5. La méthode la plus simple est d'installer ceux-ci via OPAM (OCaml preferred package manager) qui est capable de gérer de multiples versions de OCaml sur la même machine. Notez que Camlp5 doit être installé pour chaque version du compiler.

Sans OPAM, l'ancienne façon de faire est d'installer/compiler OCaml et Camlp5 par soi-même.

Lorsque OCaml est Camlp5 sont installés, vous pouvez cloner le dépôt et compiler GeneWeb.

N'oubliez pas que si votre base a été construite sur une ancienne version, elle ne sera pas compatible avec les bases construites sur une nouvelle version; elle devra être recover via le format .gw pour migrer de l'une a l'autre.


GeneWeb 7

GNU/Linux

MacOS

Windows via Cygwin

GeneWeb 6.xx avec OPAM

GNU/Linux

MacOS

Windows via Cygwin

Cloner le dépôt et compiler GeneWeb

Build options